UniFi - USW Leaf: CLI Command Comparison
Overview
This article lists the different CLI commands supported by the USW-Leaf switch and their equivalent command on a Cisco switch.
- The USW-Leaf is currently available in the Early Access store and discussed in the Beta section of the Community. To view these, please make sure you have Early Access enabled for your Ubiquiti account and that you are logged in.
- The commands with asterisks (*) below are not fully supported yet, and may change without notice.
- After logging in using SSH, use the vtysh command to enter the vtysh mode. This mode is used for switching-related commands.
Table of Contents
11. Spanning Tree (STP / RSTP) 13. Port Error Disable / Auto Recovery |
1. General Commands
Description |
USW-Leaf Command |
Cisco Command |
Show OS version information. | UBNT# show version | SW# show version |
Show base MAC address. | UBNT# show system | SW# show version |
Show USW Model. | UBNT# show platform info | SW# show version |
Show current configuration (DRAM). | UBNT# show running-config |
SW# show running-config
|
Show startup configuration (NVRAM). | UBNT# show startup-config |
SW# show startup-config
|
Show all logs that the router has in its memory. | UBNT# show log | SW# show log |
Overview all IPv4 interfaces on the switch. | UBNT# show ip interface brief |
SW# show ip interface brief
|
Display current routing protocols. | UBNT# show ip protocol |
SW# show ip protocol
|
Display IPv4 routing table. | UBNT# show ip route | SW# show ip route |
Display IPv6 routing table. | UBNT# show ipv6 route | SW# show ipv6 route |
Display access list. | UBNT# show access-list <list_name> |
SW# show access-list
|
Display MAC addresses table. | UBNT# show platform mac address-table |
SW# show mac address-table
|
Show ARP table. | UBNT# show arp | SW# show arp |
Display all users connected to the switch. | N/A | SW# show users |
Display all info about flash memory. | N/A | SW# show flash |
Display history of commands used. | N/A | SW# show history |
Display the system clock. | N/A | SW# show clock |
Information about hardware status. | UBNT# show environment | SW# show environment |
Show the amount of switch free memory. | UBNT# show memory | SW# show memory |
2. VLANs
Description |
USW-Leaf Command |
Cisco Command |
Display VLAN information, all ports which belong to specific VLAN, and information about the number of VLANs configured on the switch. | UBNT# show bridge-domain | SW# show vlan |
Create new VLAN 2. | UBNT# configure terminal UBNT(config)# bridge-domain 2 UBNT(bridge-domain)# exit UBNT(config)# |
SW# configure terminal
SW(config)# vlan 2 SW(config-vlan)# exit |
Add VLAN 2 membership to the port swp1, configure the native VLAN ID 10. NPOS operates VLAN inside bridge-domain, so it's necessary to associate port with VLAN in bridge-domain. |
UBNT(config)# interface swp1 UBNT(config-if)# switchport mode trunk UBNT(config-if)# switchport trunk allowed vlan 2 UBNT(config-if)# switchport trunk native-vlan 10 UBNT(config-if)# exit UBNT(config)# bridge-domain 2 UBNT(bridge-domain)# vlan 2 swp1 UBNT(bridge-domain)# exit UBNT(config)# bridge-domain 10 UBNT(bridge-domain)# vlan 10 swp1 UBNT(bridge-domain)# exit |
SW(config)# interface fa1/0
SW(config-if)# switchport mode trunk SW(config-if)# switchport trunk allowed vlan add 2 SW(config-if)# switchport trunk native vlan 10 SW(config-if)# exit |
Remove VLAN 2 membership from port swp1 and the native VLAN. NPOS port with VLAN association to bridge-domain is removed automatically. |
UBNT(config)# interface swp1 UBNT(config-if)# switchport trunk allowed vlan remove 2 UBNT(config-if)# no switchport trunk native-vlan UBNT(config-if)# exit |
SW(config)# interface fa1/0
SW(config-if)# switchport trunk allowed vlan remove 2 SW(config-if)# no switchport trunk native vlan SW(config-if)# exit |
Enable or disable dot1q tagging for native VLANs on specific port. Cisco's method operates dot1q native tagging globally. | UBNT(config)# vlan do1q tag native UBNT(config)# interface swp1 UBNT(config-if)# vlan dot1q tag native UBNT(config-if)# no vlan dot1q tag native UBNT(config-if)# exit |
SW(config)# vlan do1q tag native SW(config)# no vlan do1q tag native |
Configure the swp1 interface as a nontrunking nontagged single-VLAN 3 access mode. Before switching, disable the current mode. |
UBNT(config)# interface swp1 UBNT(config-if)# no switchport UBNT(config-if)# switchport mode access UBNT(config-if)# switchport access vlan 3 UBNT(config-if)# exit UBNT(config)# bridge-domain 3 UBNT(bridge-domain)# vlan 3 swp1 UBNT(bridge-domain)# exit |
SW(config)# interface fa1/0
SW(config-if)# switchport mode access SW(config-if)# switchport access vlan 3 SW(config-if)# exit |
Remove any configuration specific to Layer 2 on this interface (include VLAN's membership), switch interface to Layer 3 mode. | UBNT(config)# interface swp1 UBNT(config-if)# no switchport UBNT(config-if)# exit |
SW(config)# interface fa1/0
SW(config-if)# no switchport SW(config-if)# exit |
Disable MAC address learning on a specified VLAN 2. Maximum number of learning MAC records equal 1000. Configure a secure sticky MAC address for interface swp1. |
UBNT(config)# bridge-domain 2 UBNT(bridge-domain)# no learning enable UBNT(bridge-domain)# learning limit 1000 UBNT(bridge-domain)# learning sticky aa:bb:cc:dd:11:22 interface swp1 UBNT(bridge-domain)# exit |
SW(config)# no mac-address-table learning vlan 2
SW(config)# mac-address-table limit vlan 2 maximum 1000 SW(config)# interface fa1/0 SW(config-if)# switchport port-security mac-address aa:bb:cc:dd:11:22 SW(config-if)# exit |
3. Port Operation
Description |
USW-Leaf Command |
Cisco Command |
Show port status and admin state. | UBNT# show interface status |
SW# show interface status
|
Verify the FEC feature status on the interface. |
UBNT# show fec status
|
|
View the interface status of interface swp1. | UBNT# show port status swp1 UBNT# show interface swp1 |
SW# show interface fa1/0
|
Display interface statistics. | UBNT# show statistics interface |
SW# show interface counters
|
Clear interface statistics counters. | UBNT# show statistics clear |
SW# clear counters
|
Display information about the connected transceivers. | UBNT# show interface transceiver swp1 UBNT# show platform fwd interface sfp |
SW# show interface transceiver
|
*Information about the switchport interface. | N/A |
show interface switchport
|
Configure interface speed 100g, autonegotiation, and FEC cl-91. | UBNT(config)# interface swp54 UBNT(config-if)# speed 100g UBNT(config-if)# autonegotiation enabled UBNT(config-if)# fec cl-91 UBNT(config-if)# exit |
SW(config)# interface fa1/0
SW(config-if)# speed 100g SW(config-if)# speed auto SW(config-if)# fec cl91 SW(config-if)# exit |
Configure maximum transmission unit (MTU) size per specific interface. | UBNT(config)# interface swp54 UBNT(config-if)# mtu 9216 UBNT(config-if)# exit |
SW(config)# interface fa1/0
SW(config-if)# ip mtu 9216 SW(config-if)# end |
4. LAG (Link Aggregation)
Description |
USW-Leaf Command |
Cisco Command |
Display LACP internal information. | UBNT# show lacp internal |
SW# show lacp internal
|
Display the status of a port-channel interface. | UBNT# show interface po1 |
SW# show interface port-channel 1
|
Display the traffic statistics for port channels. | UBNT# show lacp counters |
SW# show lacp counters
|
Clear LACP counters. | UBNT# clear lacp counters |
SW# clear lacp counters
|
Display the LACP system identifier. | UBNT# show lacp sys-id |
SW# show lacp system-identifier
|
Display information about the LACP neighbor. | UBNT# show lacp neighbor |
SW# show lacp neighbor
|
Configure the LACP system-priority and priority for the physical interface. | UBNT(config)# lacp system-priority 65535 UBNT(config)# interface swp54 UBNT(config-if)# lacp port-priority priority 20000 UBNT(config-if)# exit |
SW(config)# lacp system-priority 65535
SW(config)# interface fa1/0 SW(config-if)# lacp port-priority priority 20000 SW(config-if)# exit |
Specify the port mode as active for the links in a port channel. Define the minimum and maximum number of active bundled. Define LACP ports allowed in a port channel. |
UBNT(config)# interface swp1 UBNT(config-if)# no switchport UBNT(config-if)# channel-group 1 mode active UBNT(config-if)# interface swp2 UBNT(config-if)# no switchport UBNT(config-if)# channel-group 1 mode active UBNT(config-if)# interface port-channel 1 UBNT(config-if)# lacp min-links 2 UBNT(config-if)# lacp max-bundle 8 UBNT(config-if)# exit |
SW(config)# interface fa0/1
SW(config-if)# channel-group 1 mode active SW(config-if)# interface fa0/2 SW(config-if)# channel-group 1 mode active SW(config-if)# interface port-channel 1 SW(config-if)# lacp min-links 2 SW(config-if)# lacp max-bundle 8 SW(config-if)# exit |
Delete all interfaces from port-channel interface. | UBNT(config-if)# int po1 UBNT(config-if)# delete all-lag-members UBNT(config-if)# exit |
N/A
|
5. SPAN (Port Mirroring)
Description |
USW-Leaf Command |
Cisco Command |
Display information about the Switched Port Analyzer (SPAN). | UBNT# show mirror |
SW# show monitor session
|
Set up a SPAN session (session 1) for monitoring ingress & egress port traffic to a destination port. | UBNT(config)# mirror tx session 1 UBNT(config-mirror)# source interface swp1 UBNT(config-mirror)# destination interface swp2 UBNT(config)# mirror rx session 1 UBNT(config-mirror)# source interface swp1 UBNT(config-mirror)# destination interface swp2 UBNT(config-mirror)# exit |
SW(config)# monitor session 1 source interface fastEthernet0/1 tx
SW(config)# monitor session 1 source interface fastEthernet0/1 rx SW(config)# monitor session 1 destination interface fastEthernet0/2 |
Delete SPAN sessions. | UBNT(config)# no mirror tx session 1 UBNT(config)# no mirror rx session 1 |
SW(config)# no monitor session 1
|
6. Storm Control
Description |
USW-Leaf Command |
Cisco Command |
Display storm control statistics for specified interface. | UBNT# show statistics storm-control interface swp1 |
SW# show interface fa0/1 counters storm-control
|
Traffic Storm Control Configuration (level as a percentage of the total interface bandwidth). | UBNT(config)# interface swp1 UBNT(config-if)# storm-control unicast level 50 UBNT(config-if)# storm-control multicast level 50 UBNT(config-if)# storm-control broadcast level 50 UBNT(config-if)# exit |
SW(config)# interface fa0/1
SW(config-if)# storm-control unicast level 50 SW(config-if)# storm-control multicast level 50 SW(config-if)# storm-control broadcast level 50 SW(config-if)# exit |
7. Port Isolation (Protected Port)
Description |
USW-Leaf Command |
Cisco Command |
Display protected port state for specific interface. | UBNT# show interface swp1 switchport |
SW# show interface fa0/1 switchport
|
Enable or disable the interface that will be a protected port. | UBNT(config)# interface swp1 UBNT(config-if)# switchport protected UBNT(config-if)# no switchport protected UBNT(config-if)# exit |
SW(config)# interface fa0/1
SW(config-if)# switchport protected SW(config-if)# no switchport protected SW(config-if)# exit |
8. Flow Control
Description |
USW-Leaf Command |
Cisco Command |
*Display the flow control settings.
|
N/A |
SW# show interface flowcontrol
|
Configure flow-control mode Configure flow-control priority |
UBNT(config)# interface swp1 UBNT(config-if)# flow-control mode both UBNT(config-if)# priority-flow-control mode both UBNT(config-if)# exit |
SW(config)# interface ethernet fa0/1
SW(config-if)# flowcontrol receive on SW(config-if)# flowcontrol send on SW(config-if)#priority-flow-control mode on SW(config-if)# exit |
Disable Link Level Flow Control and its priority on a specific interface. | UBNT(config)# interface swp1 UBNT(config-if)# no flow-control UBNT(config-if)# no priority-flow-control UBNT(config-if)# exit |
SW(config)# interface ethernet fa0/1
SW(config-if)# flowcontrol receive off SW(config-if)# flowcontrol send off SW(config-if)#priority-flow-control mode off SW(config-if)# exit |
9. QoS (Scheduling / Shaping / Policing)
Description |
USW-Leaf Command |
Cisco Command |
Verify existing scheduling policy, queues weight, and bound interfaces. | UBNT# show qos policy scheduling | SW# show mls qos interface queueing |
Verify existing shaping policy. | UBNT# show qos policy shape |
SW# show policy-map interface
|
Verify existing policing policy. | UBNT# show qos policy policing | |
Configure the QoS Scheduling policy, binding the policy to a specific interface. | UBNT(config)# qos policy scheduling sch_pol UBNT(qos-policy)# queue 0 dwrr 5 UBNT(qos-policy)# queue 1 dwrr 10 UBNT(qos-policy)# queue 2 dwrr 20 UBNT(qos-policy)# queue 3 dwrr 30 UBNT(qos-policy)# queue 4 dwrr 40 UBNT(qos-policy)# queue 5 dwrr 50 UBNT(qos-policy)# queue 6 dwrr 60 UBNT(qos-policy)# queue 7 dwrr 70 UBNT(qos-policy)# exit UBNT(config)# interface swp1 UBNT(config-if)# qos policy scheduling sch_pol UBNT(config-if)# exit |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# wrr-queue bandwidth 5 10 20 30 40 50 60 70 SW(config-if)# exit |
Configure the QoS Shaping policy, binding the policy to a specific interface. | UBNT(config)# qos policy shape shape_pol UBNT(qos-policy)# queue 0 min 2000 64000 max 10000 640000 UBNT(qos-policy)# queue 1 min 2000 64000 max 20000 640000 UBNT(qos-policy)# queue 2 min 2000 64000 max 20000 640000 UBNT(qos-policy)# queue 3 min 2000 64000 max 30000 640000 UBNT(qos-policy)# queue 4 min 2000 64000 max 40000 640000 UBNT(qos-policy)# queue 5 min 2000 64000 max 50000 640000 UBNT(qos-policy)# queue 6 min 2000 64000 max 60000 640000 UBNT(qos-policy)# queue 7 min 2000 64000 max 70000 640000 UBNT(qos-policy)# exit UBNT(config)# interface swp1 UBNT(config-if)# qos policy shape shape_pol UBNT(config-if)# end |
SW(config)#policy-map shape_pol SW(config-pmap)#class shape_cl SW(config-pmap-c)#shape avarage 640000 SWconfig-pmap-c)# exit SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)#service-policy output shape_pol SW(config-if)# exit |
*Configure the QoS Policing policy that utilizes two ACLs (associated with policer), binding the policy to a specific interface. | UBNT(config)# ip access-list voice-acl UBNT(config-ip-acl)# 10 permit ip 192.168.10.0/24 any UBNT(config-ip-acl)# exit UBNT(config)# ip access-list database UBNT(config-ip-acl)# 10 permit tcp any any eq 1810 UBNT(config-ip-acl)# 20 permit tcp any any eq 2481 UBNT(config-ip-acl)# 30 permit tcp any any eq 1521 UBNT(config-ip-acl)# exit UBNT(config)# policer aggregate voice-acl-aggr UBNT(qos-policer)# conform-action transmit UBNT(qos-policer)# exit UBNT(config)# policer aggregate database-aggr UBNT(qos-policer)# conform-action set-dscp 18 UBNT(qos-policer)# exit UBNT(config)# qos policy policing test-policing UBNT(qos-policy-policing)# 10 access-list voice-acl UBNT(qos-policy-policing-acl)# policer voice-acl-aggr UBNT(qos-policy-policing-acl)# exit UBNT(qos-policy-policing)# 20 access-list database UBNT(qos-policy-policing-acl)# policer database-aggr UBNT(qos-policy-policing-acl)# exit UBNT(qos-policy-policing)# exit UBNT(config)# interface swp1 UBNT(config-if)# qos policy policing test-policing input UBNT(config-if)# end |
SW(config)#ip access-list extended voice-acl SW(config-ext-nacl#permit ip 192.168.10.0 0.0.0.255 any SW(config-ext-nacl)#exit SW(config)#ip access-list extended database SW(config-ext-nacl)#permit tcp any any eq 1810 SW(config-ext-nacl)#permit tcp any any eq 2481 SW(config-ext-nacl)#permit tcp any any eq 1521 SW(config-ext-nacl)#exit SW(config)#class-map class-voice SW(config-cmap)#match access-group name voice-acl SW(config-cmap)#exit SW(config)#class-map class-database SW(config-cmap)#match access-group name database SW(config-cmap)#exit SW(config)#policy-map test-policing SW(config-pmap)#class class-voice SW(config-pmap-c)#trust cos SW(config-pmap-c)#exit SW(config-pmap)#class class-database SW(config-pmap-c)#set dscp af21 SW(config-pmap-c)#exit SW(config-pmap)#exit SW(config)#interface gigabitEthernet 1/0/1 SW(config-if)#service-policy input test-policing SW(config-if)#exit |
Unbind the scheduling, shaping and policing policies from a specific interface. | UBNT(config)# interface swp1 UBNT(config-if)# no qos policy scheduling UBNT(config-if)# no qos policy shape UBNT(config-if)# no qos policy policing input UBNT(config-if)# exit |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# no wrr-queue bandwidth SW(config-if)# no service-policy output shape_pol SW(config-if)# no service-policy input test-policing SW(config-if)# exit |
10. Access-Lists (ACL)
Description |
USW-Leaf Command |
Cisco Command |
Show the MAC access list configuration. | UBNT# show access-lists mac-acl | SW# show mac access-lists mac-acl |
Show the IP access list configuration. | UBNT# show access-lists ip-acl | SW# show ip access-lists ip-acl |
*MAC ACL Configuration | UBNT(config)# mac access-list mac-acl UBNT(config-mac-acl)# 10 permit any 0000.aaaa.0001 ffff.ffff.ffff any UBNT(config-mac-acl)# 20 permit any 0000.aaaa.0002 ffff.ffff.ffff any UBNT(config-mac-acl)# no sequence 20 UBNT(config-mac-acl)# exit |
SW(config)#mac access-list extended mac-acl SW(config-ext-macl)#permit any host 0000.aaaa.0001 SW(config-ext-macl)#permit any host 0000.aaaa.0002 SW(config-ext-macl)#no permit any host 0000.aaaa.0002 SW(config-ext-macl)#exit |
IP ACL Configuration | SW(config)# ip access-list ip-acl SW(config-ip-acl)# 10 permit ip 192.168.10.0/24 any SW(config-ip-acl)# 20 deny tcp any any eq 8080 SW(config-ip-acl)# exit |
SW(config)#ip access-list extended ip-acl SW(config-ext-ipacl)#permit ip 192.168.10.0 0.0.0.255 any SW(config-ext-ipacl)#deny tcp any any eq 8080 SW(config-ext-ipacl)#exit |
Apply MAC ACL and IP ACL to the specific interface. | UBNT(config-mac-acl)# interface swp1 UBNT(config-if)# mac access-group mac-acl in UBNT(config-if)# ip access-group ip-acl in UBNT(config-mac-acl)# exit |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# mac access-group mac-acl in SW(config-if)# ip access-group ip-acl in SW(config-if)# exit |
Remove MAC ACL and IP ACL from the specific interface. | UBNT(config-mac-acl)# interface swp1 UBNT(config-if)# no mac access-group in UBNT(config-if)# no ip access-group in UBNT(config-mac-acl)# exit |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# no mac access-group mac-acl in SW(config-if)# no ip access-group ip-acl in SW(config-if)# exit |
11. Spanning Tree (STP / RSTP)
Description |
USW-Leaf Command |
Cisco Command |
Display Spanning Tree information. | UBNT# show spanning-tree stp | SW# show spanning-tree |
Display a brief summary about STP. | UBNT# show spanning-tree interface brief | SW# show spanning-tree brief |
Display the STP interface status and configuration of specified interface. | UBNT# show spanning-tree interface swp1 | SW# show spanning-tree interface gigabitEthernet 1/0/1 |
Display Rapid Spanning Tree information. | UBNT# show spanning-tree rstp | SW# show spanning-tree |
Configure Spanning Tree Properties. | UBNT(config)# spanning-tree UBNT(config)# spanning-tree mode stp UBNT(config)# spanning-tree priority 32768 UBNT(config)# spanning-tree forward-time 15 UBNT(config)# spanning-tree max-age 20 UBNT(config)# spanning-tree hello-time 2 UBNT(config)# spanning-tree transmit hold-count 4 UBNT(config)# spanning-tree pathcost-method long UBNT(config)# exit |
SW(config)# spanning-tree SW(config)# spanning-tree mode stp SW(config)# spanning-tree priority 32768 SW(config)# spanning-tree forward-time 15 SW(config)# spanning-tree max-age 20 SW(config)# spanning-tree hello-time 2 SW(config)# spanning-tree transmit hold-count 4 SW(config)# spanning-tree pathcost-method long SW(config)# exit |
Specify that the Rapid STP is enabled. | UBNT(config)# spanning-tree mode rstp | SW(config)# spanning-tree mode rstp |
Disable Spanning Tree globally. | UBNT(config)# no spanning-tree | SW(config)#no spanning-tree |
*Enable or disable BPDU Guard for an interface. | UBNT(config)# interface swp1.1 UBNT(config-if)# spanning-tree bpdu-guard UBNT(config-if)# no spanning-tree bpdu-guard |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# spanning-tree bpduguard enable SW(config-if)# spanning-tree bpduguard disable |
*Enable or disable Loop Guard for an interface. | UBNT(config)# interface swp1.1 UBNT(config-if)# spanning-tree loopback-detection UBNT(config-if)# no spanning-tree loopback-detection |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# spanning-tree loopguard default SW(config-if)# no spanning-tree loopguard default |
*Enable or disable Root Guard for an interface. | UBNT(config)# interface swp1.1 UBNT(config-if)# spanning-tree root-guard UBNT(config-if)# no spanning-tree root-guard |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# spanning-tree guard root SW(config-if)# no spanning-tree guard root |
12. MSTP
Description |
USW-Leaf Command |
Cisco Command |
Display Multiple Spanning Tree configuration information. | UBNT# show spanning-tree mst configuration | SW# show spanning-tree mst configuration |
Display Multiple Spanning Tree specific instance information. | UBNT# show spanning-tree mst 1 status | SW# show spanning-tree mst 1 |
Displays a brief summary about specific MSTP instance. | UBNT# show spanning-tree mst 1 interface brief | |
Configure Multiple Spanning Tree Properties. | UBNT(config)# spanning-tree mode mst UBNT(config)# spanning-tree mst max-hops 22 UBNT(config)# spanning-tree mst name test_inst UBNT(config)# spanning-tree mst revision 32768 |
SW(config)# spanning-tree mode mst SW(config)# spanning-tree mst max-hops 22 SW(config)# spanning-tree mst configuration SW(config-mst)# name test_inst SW(config-mst)# revision 32768 SW(config-mst)# exit |
Configure instance priority, and add VLAN 100 to MST instance 2. | UBNT(config)# spanning-tree mst 2 priority 61440 UBNT(config)# spanning-tree instance 2 domain 100 |
SW(config)# spanning-tree mst 2 priority 61440 SW(config)# spanning-tree mst configuration SW(config-mst)# instance 2 vlan 100 SW(config-mst)# exit |
*STP/MSTP interface related commands for special interface(swp1) in specific vlan(100). | UBNT(config-if)# interface swp1.100 UBNT(config-if)# spanning-tree link-type point-to-point UBNT(config-if)# spanning-tree cost 10000 UBNT(config-if)# spanning-tree port-priority 32 UBNT(config-if)# spanning-tree edge-port |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# spanning-tree link-type point-to-point SW(config-if)# spanning-tree mst <instance-id> port-priority 32 SW(config-if)# spanning-tree mst <instance-id> cost 10000 SW(config-if)# spanning-tree portfast |
13. Port Error Disable / Auto Recovery
Description |
USW-Leaf Command |
Cisco Command |
Display the time period after which the interfaces are enabled for 'errdisable' conditions. | UBNT# show errdisable recovery | SW# show errdisable recovery |
Display the reason for the 'errdisable' status. | UBNT# show errdisable detect | SW# show errdisable detect |
Configure 'errdisable' recovery interval. | UBNT(config)# errdisable recovery interval 400 | SW(config)# errdisable recovery interval 400 |
*Enable or disable the BPDU guard 'errdisable' recovery condition. | UBNT(config)# errdisable recovery cause bpduguard UBNT(config)# no errdisable recovery cause bpduguard |
SW(config)# errdisable recovery cause bpduguard SW(config)# no errdisable recovery cause bpduguard |
14. DHCP Guard / DHCP Snooping
Description |
USW-Leaf Command |
Cisco Command |
Display DHCP guard settings. | UBNT# show ip dhcp guard | SW# show ip dhcp snooping binding |
Enable or disable DHCP Guard. | UBNT(config)# ip dhcp guard UBNT(config)# no ip dhcp guard |
SW(config)# ip dhcp snooping SW(config)# no ip dhcp snooping |
Add or remove trusted DHCP server to special VLAN (Cisco uses the trust interface approach). | UBNT(config)# ip dhcp guard vlan 23 server 172.16.1.1 UBNT(config)# no ip dhcp guard vlan 23 server 172.16.1.1 |
SW(config)# ip dhcp snooping vlan 23 SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# ip dhcp snooping trust SW(config-if)# no ip dhcp snooping trust |
15. ARP
Description |
USW-Leaf Command |
Cisco Command |
Display ARP table. | UBNT# show arp | SW# show ip arp |
Configure ARP aging time globally and per specific interface. | UBNT(config)# arp aging-time 300 UBNT(config)# int swp1 UBNT(config-if)# arp aging-time 3600 UBNT(config-if)# exit |
SW(config)# arp timeout 300 SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# arp timeout 3600 SW(config-if)# exit |
Add or remove static ARP entry. | UBNT(config)# ip arp 10.1.1.1 44:d9:e7:9e:b6:db port swp1 UBNT(config)# no ip arp 10.1.1.1 44:d9:e7:9e:b6:db |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# ip arp 10.1.1.1 44:d9:e7:9e:b6:db SW(config-if)# no ip arp 10.1.1.1 44:d9:e7:9e:b6:db |
Clear the ARP table. | UBNT# clear arp all | SW# clear ip arp |
16. DHCP Client / Static IP
Description |
USW-Leaf Command |
Cisco Command |
Overview all IPv4 interfaces on the switch. | UBNT# show ip interface brief | SW# show ip interface brief |
Enable/Disable DHCP Client on bridge-domain interface. | UBNT(config)# interface bridge 1 UBNT(config-if)# ip address dhcp UBNT(config-if)# no ip address dhcp UBNT(config-if)# exit |
SW(config)# interface vlan1 SW(config-if)# ip address dhcp SW(config-if)# no ip address dhcp SW(config-if)# exit |
Configure/Remove static IP address on interface. | UBNT(config)# interface swp1 UBNT(config-if)# ip address 172.16.0.1/24 UBNT(config-if)# no ip address 172.16.0.1/24 UBNT(config-if)# exit |
SW(config)# interface gigabitEthernet 1/0/1 SW(config-if)# ip address 172.16.0.1 255.255.255.0 SW(config-if)# no ip address 172.16.0.1 SW(config-if)# exit |
17. IP Route (Static)
Description |
USW-Leaf Command |
Cisco Command |
Display IPv4 routing table. | UBNT# sh ip route | SW# show ip route |
Configure/Remove default static route. | UBNT(config)# ip route 0.0.0.0/0 192.168.1.1 UBNT(config)# no ip route 0.0.0.0/0 192.168.1.1 |
SW(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1 SW(config)# no ip route 0.0.0.0 0.0.0.0 192.168.1.1 |
Configure/Remove static route to specific network. | UBNT(config)# ip route 172.16.1.0/24 192.168.1.1 UBNT(config)# no ip route 172.16.1.0/24 192.168.1.1 |
SW(config)# ip route 172.16.1.0 255.255.255.0 192.168.1.1 SW(config)# no ip route 172.16.1.0 255.255.255.0 192.168.1.1 |
Configure static route with administrative distance. | UBNT(config)# ip route 172.16.1.0/24 192.168.1.1 15 | SW(config)# ip route 172.16.1.0 255.255.255.0 192.168.1.1 15 |
Configure/Remove null0(blackhole) route. | UBNT(config)# ip route 172.16.1.0/24 null0 UBNT(config)# no ip route 172.16.1.0/24 null0 |
SW(config)# ip route 172.16.1.0 255.255.255.0 null0 SW(config)# no ip route 172.16.1.0 255.255.255.0 null0 |
Configure/Remove ICMP reject route. | UBNT(config)# ip route 172.16.1.0/24 reject UBNT(config)# no ip route 172.16.1.0/24 reject |
N/A |